Codificaci√≥n UTF-8 en nombres y contrase√Īas de Wi-Fi (Emoji)

En 2012, se hizo posible usar caracteres UTF-8 en nombre de una red Wi-Fi. Lo primero que viene a la mente es destacarse de la masa gris y usar emoticones Emoji en el nombre de la red. Y tambi√©n, puede crear una contrase√Īa de Emoji, luego puede informar de manera segura a sus amigos: "Con√©ctese a una red Wi-Fi para obtener queso gratis, contrase√Īa: una cerveza y una galleta".


No todos inmediatamente comenzaron a apoyar este est√°ndar. Sin embargo, pasaron 7 a√Īos y no se produjo el auge de los emoticones en los nombres de los enrutadores dom√©sticos. ¬°As√≠ que organicemos este boom ahora!
Es una pena, no todo el firmware lo permite, por ejemplo, ZyXel Keenetic 4G II con el √ļltimo firmware beta en 2017 no sabe c√≥mo usar UTF-8 en SSID. Quiz√°s de alguna manera puede configurar a trav√©s de la CLI, pero no tuve √©xito. En las nuevas versiones del firmware ZyXel, se agreg√≥ esta caracter√≠stica, pero se necesita un hardware m√°s reciente. Deje que esta sea otra raz√≥n para actualizar el enrutador. No prob√© ASUS, TP-Link y otros zool√≥gicos, inmediatamente tom√© MikroTik, porque all√≠ definitivamente funciona.

MikroTik


Realic√© mis experimentos en MicroTik hAP lite con el √ļltimo firmware estable para hoy. Lo m√°s probable es que este truco funcione en todos los micr√≥fonos con cualquier firmware.

SSID UTF-8


Cambiar el nombre es bastante simple, vaya al sitio web , copie los caracteres de la placa en el formulario, presione Ir y copie el resultado al terminal:

/interface wireless set [find name="wlan1"] ssid="\F0\9F\86\93\F0\9F\A7\80" 

En el iPhone, se ve así:

Contrase√Īa UTF-8


Cuando los invitados se dispersaron, la red Wi-Fi debe estar protegida con contrase√Īa. Tambi√©n haremos que la l√≠nea UTF-8 sea una contrase√Īa. Todos en el mismo sitio seleccionan la contrase√Īa adecuada para nosotros, haga clic en Ir. Del resultado tomamos solo el valor entre comillas y escribimos en el terminal:

 /interface wireless security-profiles set [find name="default"] mode=dynamic-keys authentication-types=wpa2-psk wpa2-pre-shared-key="\F0\9F\86\93\F0\9F\A7\80" 

Conexi√≥n con una contrase√Īa UTF-8


Y ahora la parte m√°s dif√≠cil. ¬ŅC√≥mo ingresar la contrase√Īa UTF-8? Cuando ingresas texto en mensajer√≠a instant√°nea, hay un dise√Īo de teclado especial con iconos Emoji. Pero al ingresar la contrase√Īa de Wi-Fi, ¬°solo el teclado est√°ndar est√° disponible! Puedes adivinar copiar el texto del mensaje desde el messenger y pegarlo en lugar de la contrase√Īa, pero es poco probable que funcione. Puede solicitar esta tarea a los administradores de su sistema familiar.

El usuario ky0 sugirió usar un código QR con detalles de conexión . Sin embargo, en mi iPhone este truco no funcionó.

Conecte Mac, iPhone, iPad


Así es como evité esta limitación en los dispositivos Apple: conecté la Mac a través de la consola, ¡y el resto de los iDevices descargaron el perfil de la red Wi-Fi desde la nube!

Escaneamos las redes Wi-Fi con el comando:

 /System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resources/airport -s 

Y nos conectaremos a nuestra red con la contrase√Īa dada (el terminal puede hacerlo en UTF-8, a diferencia del Habr):

 networksetup -setairportnetwork en1 [] [] 

Tengo una tarjeta de red en en1, la tuya puede diferir. Consulte con el comando:

 networksetup -listallhardwareports 



Ahora, la Mac se ha conectado con √©xito a la red, despu√©s de un tiempo corto, sincroniza las contrase√Īas en iCloud, y el iPhone pronto las descargar√° y se conectar√° a nuestro Wi-Fi por s√≠ solo.

PD: En el sistema de combate, tales contrase√Īas definitivamente no deber√≠an establecerse. Aunque el nombre de la red no los da√Īar√°, incluso si no se muestra el emotic√≥n, el dispositivo podr√° conectarse a la red. Pero establecer una contrase√Īa UTF-8 en un caf√© u oficina definitivamente no deber√≠a ser as√≠: los visitantes y colegas no apreciar√°n el humor.

En casa, ¬Ņpor qu√© no? Adem√°s, si todos los dispositivos normalmente aceptan dicha contrase√Īa, es poco probable que el vecino de Vaska pueda conectarse a dicha red. Una ventaja adicional ser√° la protecci√≥n contra la fuerza bruta y la p√©rdida de contrase√Īa en bases de datos como 3wifi.stascorp.com . El popular cracker de enrutadores RouterScan utiliza codificaci√≥n ASCII, por lo tanto, al convertir un emotic√≥n a ASCII, habr√° una cadena de crack o vac√≠a. Por cierto, verifique su enrutador, tal vez ha estado en la base de datos 3wifi durante mucho tiempo ...

¬°Lo bueno es la contrase√Īa UTF-8! Los emoticones son f√°ciles de recordar, puede usar diferentes idiomas, no solo ingl√©s + n√ļmeros + algunos caracteres especiales. Falta solo soporte nativo en gadgets. Espero que los fabricantes implementen soporte para UTF-8 junto con WPA3 .

Zyxel keenetic


El sistema operativo ZyXel Keenetic admite SSID en la codificación UTF-8 en el firmware 2.13.0 con fecha 20/09/2018
lista de dispositivos
Keenetic Giga (KN-1010)
Inicio Keenetic (KN-1110)
Keenetic 4G (KN-1210)
Keenetic Lite (KN-1310)
Omni Keenetic (KN-1410)
Ciudad Keenetic (KN-1510)
Aire Keenetic (KN-1610)
Keenetic Extra (KN-1710)
Keenetic Ultra (KN-1810)
Zyxel Keenetic Start II
Zyxel Keenetic Lite III rev.B
Zyxel Keenetic 4G III rev.B
Zyxel Keenetic Giga III
Zyxel Keenetic Ultra II
Zyxel keenetic air
Zyxel Keenetic Extra II

Para dispositivos compatibles, el SSID se cambia a través de la interfaz web.

Xiaomi


En stock, el firmware es compatible con UTF-8.
Comentario de extrawelt

Enrutadores Padavan


El enrutador Xiaomi con firmware Padavan por defecto no le permite especificar emojis como SSID. Pero desde la validación se lleva a cabo en JS, se resuelve con bastante facilidad a través de la consola del desarrollador, por ejemplo, en Chrome.

Solo necesita escribir en la consola en la página de edición SSID:
 window.validate_ssidchar = function () { return true; }; 


Para que los emojis se puedan especificar en la contrase√Īa, debe deshabilitar una funci√≥n de validaci√≥n m√°s:
 window.validate_string = function () { return true; }; 

Fuente: www.reddit.com/r/javascript/comments/5zcb8m/can_you_help_me_allow_my_router_to_accept_as_the
Gracias a ferosod por este comentario !

Android


Samsung Galaxy S8 + (Android pie) le permite pegar emojis copiados del b√ļfer tanto en el nombre de la red como en la contrase√Īa. El teclado es est√°ndar de Samsung. ( informaci√≥n de DaemonGloom ).

UPD: Gracias a todos por los comentarios, sigo actualizando el tema con sus observaciones. Me pregunto si result√≥ conectarse usando el c√≥digo QR . Tambi√©n est√°n interesados ‚Äč‚Äčen los enrutadores Asus, Tp-link, D-Link.

TODO

  • ¬ŅSoporte UTF-8 SSID en enrutadores ASUS / TP-Link / D-Link / etc?
  • ¬ŅSe conecta con una contrase√Īa UTF-8 en Windows / Linux / Android?
  • Prueba un c√≥digo QR para conectarte
  • Guion de animacion

Source: https://habr.com/ru/post/438672/


All Articles